install.phpが動かない時には、まずサーバの PHPバージョン を調べるべき。

2012年12月10日

新しくワードプレスをインストールしたところ、いきなりinstall.phpが文字化けしてました。

サーバの情報を調べてみたところ、PHPがまだ4でした・・・
昔契約したサーバなんかだと、こういうことってまだまだあるようです。
最新版のワードプレス3.4.2ですが、これは、PHP4のサーバー上では動作しません。

・・・教訓・・・

「ちょっと待て。インストール前にはPHPバージョンチェック」

ワードプレスのバージョンと動作可能なPHPバージョンについて

WordPress 日本語版 2.9 以降 3.1 以下はphp4で動作します。
PHP 4.3 以上
MySQL 4.1.2 以上
WordPress 日本語版 3.2以降からはPHP5以上が必須になります。
PHP 5.2 以上
MySQL 5.0.15以上

共著書および執筆協力している本

効果的なアプリ/Web開発のための コラボレーションツール活用入門
単行本:¥3,229
[ 2016年10月発売 ]
 
HTML5+CSS3でつくる! レスポンシブWebデザイン
単行本:¥2,786
[ 2016年3月発売 ]
 
ビジネスサイトをこれからつくる WordPressデザイン入門 サイト制作から納品までのはじめの一歩
単行本:¥2,592
Kindle版:¥2,400
[ 2016年2月発売 ]
 

コメントを書く







コメント内容