install.phpが動かない時には、まずサーバの PHPバージョン を調べるべき。

install.phpが動かない時には、まずサーバの PHPバージョン を調べるべき。


新しくワードプレスをインストールしたところ、いきなりinstall.phpが文字化けしてました。

サーバの情報を調べてみたところ、PHPがまだ4でした・・・
昔契約したサーバなんかだと、こういうことってまだまだあるようです。
最新版のワードプレス3.4.2ですが、これは、PHP4のサーバー上では動作しません。

・・・教訓・・・

「ちょっと待て。インストール前にはPHPバージョンチェック」

ワードプレスのバージョンと動作可能なPHPバージョンについて

WordPress 日本語版 2.9 以降 3.1 以下はphp4で動作します。
PHP 4.3 以上
MySQL 4.1.2 以上
WordPress 日本語版 3.2以降からはPHP5以上が必須になります。
PHP 5.2 以上
MySQL 5.0.15以上

shoko administrator

フリーランスのWeb制作者。WordPressのサイト構築、およびWebデザインとディレクション。専門学校HAL東京にてWEB学科の講師をしています。WordPressコミュニティに出没。趣味は合気道。

Leave a Reply